<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
    <title>Broward County Officials Detail Early Financial and Social Impacts of COVID-19 - Caribbean News</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.caribbeannationalweekly.com/xmlrpc.php" />
    <style>
	/* Custom BSA_PRO Styles */

	/* fonts */

	/* form */
	.bsaProOrderingForm {   }
	.bsaProInput input,
	.bsaProInput input[type='file'],
	.bsaProSelectSpace select,
	.bsaProInputsRight .bsaInputInner,
	.bsaProInputsRight .bsaInputInner label {   }
	.bsaProPrice  {  }
	.bsaProDiscount  {   }
	.bsaProOrderingForm .bsaProSubmit,
	.bsaProOrderingForm .bsaProSubmit:hover,
	.bsaProOrderingForm .bsaProSubmit:active {   }

	/* allerts */
	.bsaProAlert,
	.bsaProAlert > a,
	.bsaProAlert > a:hover,
	.bsaProAlert > a:focus {  }
	.bsaProAlertSuccess {  }
	.bsaProAlertFailed {  }

	/* stats */
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }

	.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }


	/* Custom CSS */
	
</style><meta property="og:image" content="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down.jpg" /><link rel="icon" type="image/png" href="https://www.caribbeannationalweekly.com/wp-content/uploads/2017/08/CNW-favicon-1.jpg">
<!-- This site is optimized with the Yoast SEO plugin v9.7 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="At a special County Commission workshop on Tuesday, March 24, Broward County administrators and officials shared information about the impacts of COVID-19."/>
<link rel="canonical" href="https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Broward County Officials Detail Early Financial and Social Impacts of COVID-19 - Caribbean News" />
<meta property="og:description" content="At a special County Commission workshop on Tuesday, March 24, Broward County administrators and officials shared information about the impacts of COVID-19." />
<meta property="og:url" content="https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/" />
<meta property="og:site_name" content="Caribbean News" />
<meta property="article:publisher" content="http://www.facebook.com/caribbeannationalweekly" />
<meta property="article:tag" content="broward county" />
<meta property="article:tag" content="Coronavirus" />
<meta property="article:tag" content="COVID-19" />
<meta property="article:tag" content="effects" />
<meta property="article:tag" content="financial" />
<meta property="article:tag" content="impact" />
<meta property="article:tag" content="Social" />
<meta property="article:section" content="Local" />
<meta property="article:published_time" content="2020-03-26T00:52:43+00:00" />
<meta property="og:image" content="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down.jpg" />
<meta property="og:image:secure_url" content="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down.jpg" />
<meta property="og:image:width" content="1020" />
<meta property="og:image:height" content="675" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="At a special County Commission workshop on Tuesday, March 24, Broward County administrators and officials shared information about the impacts of COVID-19." />
<meta name="twitter:title" content="Broward County Officials Detail Early Financial and Social Impacts of COVID-19 - Caribbean News" />
<meta name="twitter:image" content="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Caribbean News &raquo; Feed" href="https://www.caribbeannationalweekly.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caribbean News &raquo; Comments Feed" href="https://www.caribbeannationalweekly.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caribbean News &raquo; Broward County Officials Detail Early Financial and Social Impacts of COVID-19 Comments Feed" href="https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.caribbeannationalweekly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=b99ec9fefa475ed9eec1186276052eb8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='buy_sell_ads_pro_main_stylesheet-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/style.css?ver=b99ec9fefa475ed9eec1186276052eb8' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_template_stylesheet-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/template.css.php?ver=b99ec9fefa475ed9eec1186276052eb8' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_materialize_stylesheet-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/material-design.css?ver=b99ec9fefa475ed9eec1186276052eb8' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_animate_stylesheet-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/animate.css?ver=b99ec9fefa475ed9eec1186276052eb8' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_chart_stylesheet-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/chart.css?ver=b99ec9fefa475ed9eec1186276052eb8' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_owl_carousel_stylesheet-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/owl.carousel.css?ver=b99ec9fefa475ed9eec1186276052eb8' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/ui-datapicker.css?ver=b99ec9fefa475ed9eec1186276052eb8' type='text/css' media='all' />
<link rel='stylesheet' id='vdgk_video_stick_style-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/wp-video-sticky/library/css/style.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='lazy-load-videos-and-sticky-control-style-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/lazy-load-videos-and-sticky-control/assets/css/llvasc-public.min.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.2' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.caribbeannationalweekly.com/wp-content/themes/Newspaper/style.css?ver=8.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.caribbeannationalweekly.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-includes/js/shortcode.min.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-admin/js/media-upload.min.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/script.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.viewportchecker.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/chart.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/owl.carousel.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.simplyscroll.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/custom.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/slide-banners/swfobject/swfobject.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/slide-banners/slidebanner.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/wp-video-sticky/library/js/script.js?ver=1'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/wp-video-sticky/library/js/player.js?ver=1'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/wp-video-sticky/library/js/youtube.js?ver=1'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/wp-video-sticky/library/js/jquery-ui.js?ver=1'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/wp-video-sticky/library/js/jquery.ui.touch-punch.js?ver=1'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5953f16917a0180011089c00'></script>
<link rel='https://api.w.org/' href='https://www.caribbeannationalweekly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.caribbeannationalweekly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.caribbeannationalweekly.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://www.caribbeannationalweekly.com/?p=43740' />
<link rel="alternate" type="application/json+oembed" href="https://www.caribbeannationalweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caribbeannationalweekly.com%2Fnews%2Flocal-news%2Fbroward-county-officials-detail-early-financial-and-social-impacts-of-covid-19%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.caribbeannationalweekly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.caribbeannationalweekly.com%2Fnews%2Flocal-news%2Fbroward-county-officials-detail-early-financial-and-social-impacts-of-covid-19%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.caribbeannationalweekly.com/?wordfence_lh=1&hid=B5E9FBD2D632ECA381A25CF8224C9AE3');
</script><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.caribbeannationalweekly.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>
    
.post .td-post-header .entry-title {
		font-family:"Helvetica Neue", Helvetica, Arial, sans-serif;
	
	}
    
    body, p {
    	font-family:"Helvetica Neue", Helvetica, Arial, sans-serif;
	font-size:24px;
	
    }
</style>

<script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://www.caribbeannationalweekly.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.caribbeannationalweekly.com/category/news/",
                                "name": "News"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.caribbeannationalweekly.com/category/news/local-news/",
                                "name": "Local"                                
                            }
                        },{
                            "@type": "ListItem",
                            "position": 4,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/",
                                "name": "Broward County Officials Detail Early Financial and Social Impacts of COVID-19"                                
                            }
                        }    ]
                        }
                       </script>		<style type="text/css" id="wp-custom-css">
			h1.Pred-heading {
    font-size: 28px;
    margin-bottom: 26px;
    color: #344A96;
    font-weight: 700;
    text-transform: uppercase;
    padding-left: 13px;
}		</style>
	<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-1165955780039296",
    enable_page_level_ads: true
  });
</script></head>

<body data-rsssl=1 class="post-template-default single single-post postid-43740 single-format-standard global-block-template-1 wpb-js-composer js-comp-ver-5.7 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/caribbeannationalweekly/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/caribbeannationalweekly/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://jm.linkedin.com/company/cnw-network-caribbean-national-weekly" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/nationalweekly" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-primary-top-menu-container"><ul id="menu-primary-top-menu" class="td-mobile-main-menu"><li id="menu-item-165" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-first menu-item-165"><a href="https://www.caribbeannationalweekly.com/category/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166"><a href="https://www.caribbeannationalweekly.com/category/news/caribbean-news/">Caribbean</a></li>
	<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169"><a href="https://www.caribbeannationalweekly.com/category/news/national-news/">National</a></li>
	<li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-168"><a href="https://www.caribbeannationalweekly.com/category/news/local-news/">Local</a></li>
</ul>
</li>
<li id="menu-item-482" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-482"><a href="https://www.caribbeannationalweekly.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170"><a href="https://www.caribbeannationalweekly.com/category/sports/">Sports</a></li>
<li id="menu-item-161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-161"><a href="https://www.caribbeannationalweekly.com/category/lifestyle/">Lifestyle<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-666" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-666"><a href="https://www.caribbeannationalweekly.com/category/cuisine/">Cuisine</a></li>
	<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://www.caribbeannationalweekly.com/category/lifestyle/health-fitness/">Health &#038; Fitness</a></li>
	<li id="menu-item-14954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14954"><a href="https://www.caribbeannationalweekly.com/category/this-day-in-history/">This Day In History</a></li>
	<li id="menu-item-2636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2636"><a href="https://www.caribbeannationalweekly.com/daily-horoscope/">Weekly Horoscope</a></li>
</ul>
</li>
<li id="menu-item-483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-483"><a href="https://www.caribbeannationalweekly.com/category/community-news/">Community</a></li>
<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://www.caribbeannationalweekly.com/category/lifestyle/business/">Business</a></li>
<li id="menu-item-979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-979"><a href="https://www.caribbeannationalweekly.com/category/video/">Videos<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-160"><a href="https://www.caribbeannationalweekly.com/category/video/cnw90-news/">CNW90</a></li>
	<li id="menu-item-1004" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1004"><a href="https://www.caribbeannationalweekly.com/category/video/talkup/">TalkUp</a></li>
	<li id="menu-item-13785" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13785"><a href="https://www.caribbeannationalweekly.com/category/video/sportscast/">Sportscast</a></li>
	<li id="menu-item-4344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4344"><a href="https://www.caribbeannationalweekly.com/category/video/one-on-one/">One on One</a></li>
</ul>
</li>
<li id="menu-item-15483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15483"><a href="https://www.caribbeannationalweekly.com/category/special-features/">Features<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-15485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15485"><a href="https://www.caribbeannationalweekly.com/category/special-features/jamaica-diaspora-next-gen/">Jamaica&#8217;s Next Gen Diaspora</a></li>
	<li id="menu-item-15484" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15484"><a href="https://www.caribbeannationalweekly.com/category/special-features/guyanas-next-gen-diaspora/">Guyana&#8217;s Next Gen Diaspora</a></li>
</ul>
</li>
<li id="menu-item-17058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17058"><a href="https://www.caribbeannationalweekly.com/category/editorial/">Editorial<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-27992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27992"><a href="https://www.caribbeannationalweekly.com/category/e-paper/">E-Paper</a></li>
	<li id="menu-item-17059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17059"><a href="https://www.caribbeannationalweekly.com/category/editorial/op-ed/">Op-Ed</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.caribbeannationalweekly.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 3
-->

<div class="td-header-wrap td-header-style-3">

    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            <!-- LOGIN MODAL -->
        </div>
    </div>

    <div class="td-banner-wrap-full td-container-wrap ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="https://www.caribbeannationalweekly.com/">
            <img class="td-retina-data" data-retina="https://www.caribbeannationalweekly.com/wp-content/uploads/2015/08/National-Weekly-HEADER-LOGO-retina-alt.png" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2015/08/National-Weekly-HEADER-LOGO-alt.png" alt=""/>
            <span class="td-visual-hidden">Caribbean News</span>
        </a>
                </div>
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_1_5e7c94c7a9d2b_rand td_block_template_1"><div id="bsa-html" class="bsaProContainer bsaProContainer-9 bsa-html bsa-pro-col-1"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><A HREF="http://www.historymiami.org/exhibition/embracing-the-lens-the-blackflorida-project/">

<IMG SRC="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/HistoryMiami-Museum3.gif" BORDER=0 WIDTH=728 HEIGHT=90 ALT="Advertisement"></A></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-9');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</div>
</div>            </div>
        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-mobile" href="https://www.caribbeannationalweekly.com/">
			<img class="td-retina-data" data-retina="https://www.caribbeannationalweekly.com/wp-content/uploads/2017/11/CNW-logo-retina.png" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2017/11/CNW-logo-mobile.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-mobile" href="https://www.caribbeannationalweekly.com/">
			<img class="td-retina-data" data-retina="https://www.caribbeannationalweekly.com/wp-content/uploads/2015/08/National-Weekly-HEADER-LOGO-retina-alt.png" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2015/08/National-Weekly-HEADER-LOGO-alt.png" alt=""/>
		</a>
	    </div>
    <div class="menu-primary-top-menu-container"><ul id="menu-primary-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-165"><a href="https://www.caribbeannationalweekly.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-166"><a href="https://www.caribbeannationalweekly.com/category/news/caribbean-news/">Caribbean</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-169"><a href="https://www.caribbeannationalweekly.com/category/news/national-news/">National</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-168"><a href="https://www.caribbeannationalweekly.com/category/news/local-news/">Local</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-482"><a href="https://www.caribbeannationalweekly.com/category/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-170"><a href="https://www.caribbeannationalweekly.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-161"><a href="https://www.caribbeannationalweekly.com/category/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-666"><a href="https://www.caribbeannationalweekly.com/category/cuisine/">Cuisine</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-163"><a href="https://www.caribbeannationalweekly.com/category/lifestyle/health-fitness/">Health &#038; Fitness</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14954"><a href="https://www.caribbeannationalweekly.com/category/this-day-in-history/">This Day In History</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2636"><a href="https://www.caribbeannationalweekly.com/daily-horoscope/">Weekly Horoscope</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-483"><a href="https://www.caribbeannationalweekly.com/category/community-news/">Community</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-162"><a href="https://www.caribbeannationalweekly.com/category/lifestyle/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-979"><a href="https://www.caribbeannationalweekly.com/category/video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-160"><a href="https://www.caribbeannationalweekly.com/category/video/cnw90-news/">CNW90</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1004"><a href="https://www.caribbeannationalweekly.com/category/video/talkup/">TalkUp</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-13785"><a href="https://www.caribbeannationalweekly.com/category/video/sportscast/">Sportscast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4344"><a href="https://www.caribbeannationalweekly.com/category/video/one-on-one/">One on One</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-15483"><a href="https://www.caribbeannationalweekly.com/category/special-features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-15485"><a href="https://www.caribbeannationalweekly.com/category/special-features/jamaica-diaspora-next-gen/">Jamaica&#8217;s Next Gen Diaspora</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-15484"><a href="https://www.caribbeannationalweekly.com/category/special-features/guyanas-next-gen-diaspora/">Guyana&#8217;s Next Gen Diaspora</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-17058"><a href="https://www.caribbeannationalweekly.com/category/editorial/">Editorial</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-27992"><a href="https://www.caribbeannationalweekly.com/category/e-paper/">E-Paper</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-17059"><a href="https://www.caribbeannationalweekly.com/category/editorial/op-ed/">Op-Ed</a></li>
</ul>
</li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://www.caribbeannationalweekly.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.caribbeannationalweekly.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in News" class="entry-crumb" href="https://www.caribbeannationalweekly.com/category/news/">News</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Local" class="entry-crumb" href="https://www.caribbeannationalweekly.com/category/news/local-news/">Local</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Broward County Officials Detail Early Financial and Social Impacts of COVID-19</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-43740" class="post-43740 post type-post status-publish format-standard has-post-thumbnail hentry category-caribbean-breaking-news-featured category-local-news category-news tag-coronavirus tag-covid-19 tag-effects tag-financial tag-impact tag-social" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://www.caribbeannationalweekly.com/category/news/">News</a></li><li class="entry-category"><a  href="https://www.caribbeannationalweekly.com/category/news/local-news/">Local</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Broward County Officials Detail Early Financial and Social Impacts of COVID-19</h1>

                

                <div class="td-module-meta-info">
                                        <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-03-25T20:52:43+00:00" >March 25, 2020</time></span>                                                        </div>

            </header>

        </div>

        <div class="td-post-sharing td-post-sharing-top ">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caribbeannationalweekly.com%2Fnews%2Flocal-news%2Fbroward-county-officials-detail-early-financial-and-social-impacts-of-covid-19%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Broward+County+Officials+Detail+Early+Financial+and+Social+Impacts+of+COVID-19&url=https%3A%2F%2Fwww.caribbeannationalweekly.com%2Fnews%2Flocal-news%2Fbroward-county-officials-detail-early-financial-and-social-impacts-of-covid-19%2F&via=Caribbean+News"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/&amp;media=https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down.jpg&description=At a special County Commission workshop on Tuesday, March 24, Broward County administrators and officials shared information about the impacts of COVID-19." onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Broward+County+Officials+Detail+Early+Financial+and+Social+Impacts+of+COVID-19%20-%20https%3A%2F%2Fwww.caribbeannationalweekly.com%2Fnews%2Flocal-news%2Fbroward-county-officials-detail-early-financial-and-social-impacts-of-covid-19%2F" ><i class="td-icon-whatsapp"></i></a>
	            </div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><a href="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down.jpg" data-caption=""><img width="696" height="461" class="entry-thumb td-modal-image" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down-696x461.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down-696x461.jpg 696w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down-300x199.jpg 300w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down-768x508.jpg 768w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down-635x420.jpg 635w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down.jpg 1020w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="business shut down"/></a></div>
        <div class="td-a-rec td-a-rec-id-content_inline  td_uid_2_5e7c94c7c1c3c_rand td_block_template_1"></div><p><strong>BROWARD COUNTY, FL</strong> – At a special County Commission workshop on Tuesday, March 24, County Administrator Bertha Henry and directors of the County’s economic engines, transportation and human services agencies shared information about the local financial and social service impacts of COVID-19.
<p>&nbsp;
<p><strong>Broward’s Fort Lauderdale-Hollywood International Airport (FLL)</strong>
<p><strong> </strong>Airline traffic is significantly down, and the airport is now operating at a 30-35 percent capacity. Reductions in service are expected to continue into April. The number of international destinations has dropped from 55 to 13. The remaining destinations are primarily to the Caribbean. Sixty-six of 99 concession locations in the terminals have closed.
<p>Aviation Director Mark Gale said that the economic stimulus packages now being considered by Congress should help both the airline industry and airports across the country. Expenditures are being reduced in the most prudent ways possible. Broward County is creating programs to help its 20,000+ airport workers, and vendors, by offering small business assistance and looking at opportunities for reducing rent.
<p>&nbsp;
<p><strong>Broward County’s Port Everglades</strong>
<p>The last passenger ship to come into Port Everglades was March 20. Due to the temporary slowdown of the cruise industry, the number of ships out of the Port has decreased by 66 sailings so far this season. 664 cruise ships were anticipated this season. The ferry to the Bahamas continues, but at a reduced level.
<p>Cargo operations are strong with perishable food distribution up for the year to date. With reduced airline traffic, however, jet fuel revenues are starting to decline. Construction projects at the Port are continuing as planned. Petroleum volumes are still strong.
<p>&nbsp;
<p><strong>Greater Fort Lauderdale Convention &amp; Visitors Bureau (GFLCVB)</strong>
<p>Broward hotel occupancy rates since March 15 have been between 10 and 14 percent. To date, Broward has experienced an $8.5 million loss in room revenue with an overall economic impact of $61.7 million. One major hotel has furloughed 80 percent of its staff.
<p>With the anticipated slowing of the tourism industry, the GFLCVB is looking ahead to its summer and fall campaigns. A Virtual Vacation option showcasing the best of what Broward has to offer is being developed to get potential visitors excited about a future visit here. A planned summer marketing campaign to the drive market will focus on “Lauderdeals,” expanding such successful signature celebrations as “Spa-tember” and “Restaurant Month.”
<p>&nbsp;
<p><strong>Broward County Transportation (BCT)</strong>
<p>BCT and Paratransit services (TOPS) are experiencing declines in ridership. Beginning March 28, BCT will operate on a Saturday schedule, Monday through Saturday. Sunday schedules continue with no change. Adjustments have been made in boarding procedures to encourage social distancing between riders and drivers. Customers, except for those who use the wheelchair ramp at the front door of the bus, will enter and exit the bus only via the rear doors. Also, bus fares have been suspended.
<p>&nbsp;
<p><strong>Broward County Human Services
<p></strong>County Commissioners expressed concern about those in our community who are most vulnerable in this type of crisis, such as the elderly and those who may have suddenly lost self-sufficiency, or are on the verge of losing self-sufficiency.
<p>Human Services agencies are working with Feeding South Florida to get meals to those who are experiencing food insecurity. Welfare visits to elderly residents are switching to phone calls, and ongoing training required for personnel is being conducted via SKYPE and teleconferencing. Counseling services are being provided by virtual means.
<p>The Homeless Initiative Partnership (HIP) is working closely with the Homeless Continuum of Care shelter providers, day respite and meal program providers.
<p>&nbsp;
<p><strong>Broward Sheriff’s Office (BSO)<br />
</strong>
<p>Sheriff Gregory Tony updated the County Commission on BSO activities, and steps being taken to help prevent the spread of COVID-19 among law enforcement first responders.
<p>Deputies are engaged in educating business owners on the requirements of County Administrator Bertha Henry’s recent <a href="https://www.broward.org/CoronaVirus/Documents/BerthaHenryExecutiveOrder20-01.pdf" target="_blank" rel="noopener">Emergency Order</a> to close all non-essential businesses.
<p>Evictions have essentially stopped, and deputies are reducing their physical presence at court appearances.
<p><strong>County Administrator’s Report</strong>
<p>County Administrator Bertha Henry reported that the County is continuing to provide the essential services that our community relies on, and providing alternative means of accessing those services whenever possible, to reduce foot traffic in county buildings. Further, despite every County employee’s role as a first responder in an emergency, approximately 1,200 employees whose work responsibilities are conducive to working from home, have been deemed eligible to telework and/or are being evaluated for telework. Due to the essential and sensitive nature of many of the County’s services, not all employees are eligible for telework. Requests for telework are evaluated on a case-by-case basis. The County is also being very liberal with its leave policies, to ensure that employees who wish to use accumulated annual or sick leave are permitted to do so.<strong><br />
</strong>
<p>Watch the workshop in its entirety <a href="https://vimeo.com/399158059" target="_blank" rel="noopener">here</a>.
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.caribbeannationalweekly.com/tag/broward-county/">broward county</a></li><li><a href="https://www.caribbeannationalweekly.com/tag/coronavirus/">Coronavirus</a></li><li><a href="https://www.caribbeannationalweekly.com/tag/covid-19/">COVID-19</a></li><li><a href="https://www.caribbeannationalweekly.com/tag/effects/">effects</a></li><li><a href="https://www.caribbeannationalweekly.com/tag/financial/">financial</a></li><li><a href="https://www.caribbeannationalweekly.com/tag/impact/">impact</a></li><li><a href="https://www.caribbeannationalweekly.com/tag/social/">Social</a></li></ul>            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.caribbeannationalweekly.com%2Fnews%2Flocal-news%2Fbroward-county-officials-detail-early-financial-and-social-impacts-of-covid-19%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Broward+County+Officials+Detail+Early+Financial+and+Social+Impacts+of+COVID-19&url=https%3A%2F%2Fwww.caribbeannationalweekly.com%2Fnews%2Flocal-news%2Fbroward-county-officials-detail-early-financial-and-social-impacts-of-covid-19%2F&via=Caribbean+News"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/&amp;media=https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down.jpg&description=At a special County Commission workshop on Tuesday, March 24, Broward County administrators and officials shared information about the impacts of COVID-19." onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Broward+County+Officials+Detail+Early+Financial+and+Social+Impacts+of+COVID-19%20-%20https%3A%2F%2Fwww.caribbeannationalweekly.com%2Fnews%2Flocal-news%2Fbroward-county-officials-detail-early-financial-and-social-impacts-of-covid-19%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/" data-text="Broward County Officials Detail Early Financial and Social Impacts of COVID-19" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.caribbeannationalweekly.com/lifestyle/home-confinement-because-of-covid-19-doesnt-need-to-be-boring/">Home Confinement because of COVID-19 Doesn’t Need to be Boring</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.caribbeannationalweekly.com/author/smcleod/">Sheri-Kae McLeod</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Sheri-Kae McLeod"></span><meta itemprop="datePublished" content="2020-03-25T20:52:43+00:00"><meta itemprop="dateModified" content="2020-03-25T20:52:43+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caribbeannationalweekly.com/wp-content/uploads/2015/08/National-Weekly-HEADER-LOGO-alt.png"></span><meta itemprop="name" content="Caribbean News"></span><meta itemprop="headline " content="Broward County Officials Detail Early Financial and Social Impacts of COVID-19"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down.jpg"><meta itemprop="width" content="1020"><meta itemprop="height" content="675"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_3_5e7c94c7c88b7_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_3_5e7c94c7c88b7" ><script>var block_td_uid_3_5e7c94c7c88b7 = new tdBlock();
block_td_uid_3_5e7c94c7c88b7.id = "td_uid_3_5e7c94c7c88b7";
block_td_uid_3_5e7c94c7c88b7.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5e7c94c7c88b7_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_3_5e7c94c7c88b7_rand","tdc_css_class_style":"td_uid_3_5e7c94c7c88b7_rand_style","live_filter":"cur_post_same_categories","live_filter_cur_post_id":43740,"live_filter_cur_post_author":"101360","block_template_id":""}';
block_td_uid_3_5e7c94c7c88b7.td_column_number = "3";
block_td_uid_3_5e7c94c7c88b7.block_type = "td_block_related_posts";
block_td_uid_3_5e7c94c7c88b7.post_count = "3";
block_td_uid_3_5e7c94c7c88b7.found_posts = "8359";
block_td_uid_3_5e7c94c7c88b7.header_color = "";
block_td_uid_3_5e7c94c7c88b7.ajax_pagination_infinite_stop = "";
block_td_uid_3_5e7c94c7c88b7.max_num_pages = "2787";
tdBlocksArray.push(block_td_uid_3_5e7c94c7c88b7);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_4_5e7c94c80f6d1" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_3_5e7c94c7c88b7" href="#">RELATED ARTICLES</a><a id="td_uid_5_5e7c94c80f6d6" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_3_5e7c94c7c88b7" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_3_5e7c94c7c88b7 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/lifestyle/home-confinement-because-of-covid-19-doesnt-need-to-be-boring/" rel="bookmark" title="Home Confinement because of COVID-19 Doesn’t Need to be Boring"><img width="218" height="150" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/indoor-activities-218x150.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/indoor-activities-218x150.jpg 218w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/indoor-activities-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Home Confinement because of COVID-19 Doesn’t Need to be Boring"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/lifestyle/home-confinement-because-of-covid-19-doesnt-need-to-be-boring/" rel="bookmark" title="Home Confinement because of COVID-19 Doesn’t Need to be Boring">Home Confinement because of COVID-19 Doesn’t Need to be Boring</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/caribbean-must-prepare-against-food-shortages-because-of-covid-19/" rel="bookmark" title="Caribbean Must Prepare Against Food Shortages because of COVID-19"><img width="218" height="150" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2019/12/haiti-food-relief-218x150.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2019/12/haiti-food-relief-218x150.jpg 218w, https://www.caribbeannationalweekly.com/wp-content/uploads/2019/12/haiti-food-relief-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Caribbean Must Prepare Against Food Shortages because of COVID-19"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/caribbean-must-prepare-against-food-shortages-because-of-covid-19/" rel="bookmark" title="Caribbean Must Prepare Against Food Shortages because of COVID-19">Caribbean Must Prepare Against Food Shortages because of COVID-19</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/news/st-vincent-warns-against-using-drugs-to-treat-lupus-and-malaria-for-coronavirus/" rel="bookmark" title="St Vincent Warns Against Using Drugs to Treat Lupus and Malaria for Coronavirus"><img width="218" height="150" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/palm-beach-county-covid-19-218x150.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/palm-beach-county-covid-19-218x150.jpg 218w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/palm-beach-county-covid-19-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="St Vincent Warns Against Using Drugs to Treat Lupus and Malaria for Coronavirus"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/news/st-vincent-warns-against-using-drugs-to-treat-lupus-and-malaria-for-coronavirus/" rel="bookmark" title="St Vincent Warns Against Using Drugs to Treat Lupus and Malaria for Coronavirus">St Vincent Warns Against Using Drugs to Treat Lupus and Malaria for Coronavirus</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5e7c94c7c88b7" data-td_block_id="td_uid_3_5e7c94c7c88b7"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5e7c94c7c88b7" data-td_block_id="td_uid_3_5e7c94c7c88b7"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.caribbeannationalweekly.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='43740' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a97cb3f7e7" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="68"/></p>			</form>
			</div><!-- #respond -->
	    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>CNW TV</span></h4>			<div class="textwidget"><div style="position: relative; padding-bottom: 56%; height: 0;"><iframe style="position: absolute; top: 0; left: 0; width: 100%; height: 100%;" src="//app.viloud.tv/player/embed/channel/d775cb35f5064b507a3a6ace0b1e0392?autoplay=1&amp;volume=0&amp;controls=1&amp;title=0&amp;share=0&amp;random=0" frameborder="0" allowfullscreen=""></iframe></div>
<p>&nbsp;</p>
</div>
		</aside><div id="bsa-html" class="bsaProContainer bsaProContainer-10 bsa-html bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title"
					  style="color:">
					<span>- Advertisement -</span>
				  </h3>	<a class="bsaProHeader__formUrl" href="http://example.com/ordering_form?sid=10" target="_blank" style="color:">
					<span></span>
				</a></div><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><A HREF="https://amerijet.com/">

<IMG SRC="https://www.caribbeannationalweekly.com/wp-content/uploads/2018/12/amerijet-general-300-x-250.jpg" BORDER=0 WIDTH=300 HEIGHT=250 ALT="Advertisement"></A></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-10');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					<div class="td_block_wrap td_block_7 td_block_widget td_uid_6_5e7c94c825246_rand td_with_ajax_pagination td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_6_5e7c94c825246" ><script>var block_td_uid_6_5e7c94c825246 = new tdBlock();
block_td_uid_6_5e7c94c825246.id = "td_uid_6_5e7c94c825246";
block_td_uid_6_5e7c94c825246.atts = '{"limit":"6","sort":"random_7_day","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"LATEST NEWS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"load_more","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_6_5e7c94c825246_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_6_5e7c94c825246_rand","tdc_css_class_style":"td_uid_6_5e7c94c825246_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_6_5e7c94c825246.td_column_number = "1";
block_td_uid_6_5e7c94c825246.block_type = "td_block_7";
block_td_uid_6_5e7c94c825246.post_count = "6";
block_td_uid_6_5e7c94c825246.found_posts = "43";
block_td_uid_6_5e7c94c825246.header_color = "#";
block_td_uid_6_5e7c94c825246.ajax_pagination_infinite_stop = "";
block_td_uid_6_5e7c94c825246.max_num_pages = "8";
tdBlocksArray.push(block_td_uid_6_5e7c94c825246);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">LATEST NEWS</span></h4></div><div id=td_uid_6_5e7c94c825246 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/jamaica-bans-all-incoming-travel-and-closes-seaports-for-14-days/" rel="bookmark" title="Jamaica Bans All Incoming Travel And Closes Seaports for 14 Days"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/jamaica-airport-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/jamaica-airport-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/jamaica-airport-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Jamaica Bans All Incoming Travel And Closes Seaports for 14 Days"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/jamaica-bans-all-incoming-travel-and-closes-seaports-for-14-days/" rel="bookmark" title="Jamaica Bans All Incoming Travel And Closes Seaports for 14 Days">Jamaica Bans All Incoming Travel And Closes Seaports for 14 Days</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-20T22:57:35+00:00" >March 20, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/news/caribbean-news/sandals-and-beaches-resorts-to-close-due-to-covid-19/" rel="bookmark" title="Sandals and Beaches Resorts to Close Due to COVID-19"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/sandals-Montego-Bay-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/sandals-Montego-Bay-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/sandals-Montego-Bay-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Sandals and Beaches Resorts to Close Due to COVID-19"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/news/caribbean-news/sandals-and-beaches-resorts-to-close-due-to-covid-19/" rel="bookmark" title="Sandals and Beaches Resorts to Close Due to COVID-19">Sandals and Beaches Resorts to Close Due to COVID-19</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-22T14:14:04+00:00" >March 22, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/community-news/more-than-64000-computer-devices-distributed-to-bcps-students/" rel="bookmark" title="More Than 64,000 Computer Devices Distributed to BCPS Students"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/BCPS-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/BCPS-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/BCPS-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="More Than 64,000 Computer Devices Distributed to BCPS Students"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/community-news/more-than-64000-computer-devices-distributed-to-bcps-students/" rel="bookmark" title="More Than 64,000 Computer Devices Distributed to BCPS Students">More Than 64,000 Computer Devices Distributed to BCPS Students</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-22T12:01:17+00:00" >March 22, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/caribbean-must-prepare-against-food-shortages-because-of-covid-19/" rel="bookmark" title="Caribbean Must Prepare Against Food Shortages because of COVID-19"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2019/12/haiti-food-relief-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2019/12/haiti-food-relief-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2019/12/haiti-food-relief-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Caribbean Must Prepare Against Food Shortages because of COVID-19"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/caribbean-must-prepare-against-food-shortages-because-of-covid-19/" rel="bookmark" title="Caribbean Must Prepare Against Food Shortages because of COVID-19">Caribbean Must Prepare Against Food Shortages because of COVID-19</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-25T17:23:32+00:00" >March 25, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/community-news/broward-county-public-schools-assisting-students-with-covid-19-through-feeding-sites-and-distribution-of-computers/" rel="bookmark" title="Broward County Public Schools Assisting Students With COVID-19 Through Feeding Sites and Distribution of Computers"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/broward_press_conference_nbc_6_screenshot-100x70.png" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/broward_press_conference_nbc_6_screenshot-100x70.png 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/broward_press_conference_nbc_6_screenshot-218x150.png 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Broward County Public Schools Assisting Students With COVID-19 Through Feeding Sites and Distribution of Computers"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/community-news/broward-county-public-schools-assisting-students-with-covid-19-through-feeding-sites-and-distribution-of-computers/" rel="bookmark" title="Broward County Public Schools Assisting Students With COVID-19 Through Feeding Sites and Distribution of Computers">Broward County Public Schools Assisting Students With COVID-19 Through Feeding Sites...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-24T21:10:13+00:00" >March 24, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/entertainment/young-jamaican-singer-jahzan-mclaughlin-shines-on-american-idol/" rel="bookmark" title="Young Jamaican Singer Jahzan McLaughlin Shines on American Idol"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/Jahzan-McLaughlin-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/Jahzan-McLaughlin-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/Jahzan-McLaughlin-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Young Jamaican Singer Jahzan McLaughlin Shines on American Idol"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/entertainment/young-jamaican-singer-jahzan-mclaughlin-shines-on-american-idol/" rel="bookmark" title="Young Jamaican Singer Jahzan McLaughlin Shines on American Idol">Young Jamaican Singer Jahzan McLaughlin Shines on American Idol</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-23T13:01:36+00:00" >March 23, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div><div class="td-load-more-wrap"><a href="#" class="td_ajax_load_more td_ajax_load_more_js" id="next-page-td_uid_6_5e7c94c825246" data-td_block_id="td_uid_6_5e7c94c825246">Load more<i class="td-icon-font td-icon-menu-down"></i></a></div></div> <!-- ./block --><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-2959011301651437",
    enable_page_level_ads: true
  });
</script></div></aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_uid_8_5e7c94c84dc5a_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_8_5e7c94c84dc5a" ><script>var block_td_uid_8_5e7c94c84dc5a = new tdBlock();
block_td_uid_8_5e7c94c84dc5a.id = "td_uid_8_5e7c94c84dc5a";
block_td_uid_8_5e7c94c84dc5a.atts = '{"limit":3,"sort":"featured","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"EDITOR PICKS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_8_5e7c94c84dc5a_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_8_5e7c94c84dc5a_rand","tdc_css_class_style":"td_uid_8_5e7c94c84dc5a_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_8_5e7c94c84dc5a.td_column_number = "1";
block_td_uid_8_5e7c94c84dc5a.block_type = "td_block_7";
block_td_uid_8_5e7c94c84dc5a.post_count = "3";
block_td_uid_8_5e7c94c84dc5a.found_posts = "7159";
block_td_uid_8_5e7c94c84dc5a.header_color = "";
block_td_uid_8_5e7c94c84dc5a.ajax_pagination_infinite_stop = "";
block_td_uid_8_5e7c94c84dc5a.max_num_pages = "2387";
tdBlocksArray.push(block_td_uid_8_5e7c94c84dc5a);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">EDITOR PICKS</span></h4></div><div id=td_uid_8_5e7c94c84dc5a class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/" rel="bookmark" title="Broward County Officials Detail Early Financial and Social Impacts of COVID-19"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/business-shut-down-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Broward County Officials Detail Early Financial and Social Impacts of COVID-19"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/news/local-news/broward-county-officials-detail-early-financial-and-social-impacts-of-covid-19/" rel="bookmark" title="Broward County Officials Detail Early Financial and Social Impacts of COVID-19">Broward County Officials Detail Early Financial and Social Impacts of COVID-19</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-25T20:52:43+00:00" >March 25, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/lifestyle/home-confinement-because-of-covid-19-doesnt-need-to-be-boring/" rel="bookmark" title="Home Confinement because of COVID-19 Doesn’t Need to be Boring"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/indoor-activities-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/indoor-activities-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/indoor-activities-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Home Confinement because of COVID-19 Doesn’t Need to be Boring"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/lifestyle/home-confinement-because-of-covid-19-doesnt-need-to-be-boring/" rel="bookmark" title="Home Confinement because of COVID-19 Doesn’t Need to be Boring">Home Confinement because of COVID-19 Doesn’t Need to be Boring</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-25T17:41:17+00:00" >March 25, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/caribbean-must-prepare-against-food-shortages-because-of-covid-19/" rel="bookmark" title="Caribbean Must Prepare Against Food Shortages because of COVID-19"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2019/12/haiti-food-relief-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2019/12/haiti-food-relief-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2019/12/haiti-food-relief-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Caribbean Must Prepare Against Food Shortages because of COVID-19"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/caribbean-must-prepare-against-food-shortages-because-of-covid-19/" rel="bookmark" title="Caribbean Must Prepare Against Food Shortages because of COVID-19">Caribbean Must Prepare Against Food Shortages because of COVID-19</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-25T17:23:32+00:00" >March 25, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_uid_9_5e7c94c88efdf_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_9_5e7c94c88efdf" ><script>var block_td_uid_9_5e7c94c88efdf = new tdBlock();
block_td_uid_9_5e7c94c88efdf.id = "td_uid_9_5e7c94c88efdf";
block_td_uid_9_5e7c94c88efdf.atts = '{"limit":3,"sort":"popular","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"POPULAR POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_9_5e7c94c88efdf_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_9_5e7c94c88efdf_rand","tdc_css_class_style":"td_uid_9_5e7c94c88efdf_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_9_5e7c94c88efdf.td_column_number = "1";
block_td_uid_9_5e7c94c88efdf.block_type = "td_block_7";
block_td_uid_9_5e7c94c88efdf.post_count = "3";
block_td_uid_9_5e7c94c88efdf.found_posts = "10714";
block_td_uid_9_5e7c94c88efdf.header_color = "";
block_td_uid_9_5e7c94c88efdf.ajax_pagination_infinite_stop = "";
block_td_uid_9_5e7c94c88efdf.max_num_pages = "3572";
tdBlocksArray.push(block_td_uid_9_5e7c94c88efdf);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">POPULAR POSTS</span></h4></div><div id=td_uid_9_5e7c94c88efdf class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/for-the-first-time-in-history-an-american-airlines-flight-has-all-jamaican-crew/" rel="bookmark" title="For the First Time in History, An American Airlines Flight has All-Jamaican Crew"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/02/All-Jamaican-flight-e1582666635934-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/02/All-Jamaican-flight-e1582666635934-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2020/02/All-Jamaican-flight-e1582666635934-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="For the First Time in History, An American Airlines Flight has All-Jamaican Crew"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/for-the-first-time-in-history-an-american-airlines-flight-has-all-jamaican-crew/" rel="bookmark" title="For the First Time in History, An American Airlines Flight has All-Jamaican Crew">For the First Time in History, An American Airlines Flight has...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-25T16:37:54+00:00" >February 25, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/jamaican-janice-smith-makes-history-as-navy-commander/" rel="bookmark" title="Jamaican Janice Smith makes history as Navy Commander"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2016/06/Change-of-Command-DSC_0337-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2016/06/Change-of-Command-DSC_0337-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2016/06/Change-of-Command-DSC_0337-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Jamaican Janice Smith makes history as Navy Commander" title="Jamaican Janice Smith makes history as Navy Commander"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/caribbean-breaking-news-featured/jamaican-janice-smith-makes-history-as-navy-commander/" rel="bookmark" title="Jamaican Janice Smith makes history as Navy Commander">Jamaican Janice Smith makes history as Navy Commander</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-06-01T14:10:56+00:00" >June 1, 2016</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/news/caribbean-news/recipe-bahama-breeze-mock-jerk-chicken-pasta/" rel="bookmark" title="Recipe: Bahama Breeze mock Jerk Chicken Pasta"><img width="100" height="70" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2017/05/BB-JerkChickenPasta-100x70.jpg" srcset="https://www.caribbeannationalweekly.com/wp-content/uploads/2017/05/BB-JerkChickenPasta-100x70.jpg 100w, https://www.caribbeannationalweekly.com/wp-content/uploads/2017/05/BB-JerkChickenPasta-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Recipe: Bahama Breeze mock Jerk Chicken Pasta"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/news/caribbean-news/recipe-bahama-breeze-mock-jerk-chicken-pasta/" rel="bookmark" title="Recipe: Bahama Breeze mock Jerk Chicken Pasta">Recipe: Bahama Breeze mock Jerk Chicken Pasta</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-05-10T14:48:49+00:00" >May 10, 2017</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_popular_categories td_uid_10_5e7c94c9a03f5_rand widget widget_categories td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_10_5e7c94c9a03f5" ><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">POPULAR CATEGORY</span></h4></div><ul class="td-pb-padding-side"><li><a href="https://www.caribbeannationalweekly.com/category/news/">News<span class="td-cat-no">3346</span></a></li><li><a href="https://www.caribbeannationalweekly.com/category/news/caribbean-news/">Caribbean<span class="td-cat-no">2413</span></a></li><li><a href="https://www.caribbeannationalweekly.com/category/sports/">Sports<span class="td-cat-no">1568</span></a></li><li><a href="https://www.caribbeannationalweekly.com/category/news/local-news/">Local<span class="td-cat-no">1365</span></a></li><li><a href="https://www.caribbeannationalweekly.com/category/news/caribbean-news/jamaica-news/">Jamaica<span class="td-cat-no">1168</span></a></li><li><a href="https://www.caribbeannationalweekly.com/category/entertainment/">Entertainment<span class="td-cat-no">1070</span></a></li><li><a href="https://www.caribbeannationalweekly.com/category/community-news/">Community<span class="td-cat-no">940</span></a></li><li><a href="https://www.caribbeannationalweekly.com/category/lifestyle/">Lifestyle<span class="td-cat-no">538</span></a></li><li><a href="https://www.caribbeannationalweekly.com/category/video/">Video<span class="td-cat-no">503</span></a></li></ul></div> <!-- ./block -->                            </div>
        </div>
    </div>
    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.caribbeannationalweekly.com/"><img class="td-retina-data" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2015/08/National-Weekly-HEADER-LOGO-alt.png" data-retina="https://www.caribbeannationalweekly.com/wp-content/uploads/2015/08/National-Weekly-HEADER-LOGO-retina-alt.png" alt="" title="" width="" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/caribbeannationalweekly/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/caribbeannationalweekly/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://jm.linkedin.com/company/cnw-network-caribbean-national-weekly" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/nationalweekly" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></aside></div>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                        <div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-39" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-39"><a href="#">Disclaimer</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-40"><a href="#">Privacy</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-41"><a href="#">Advertisement</a></li>
<li id="menu-item-42" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42"><a href="https://www.caribbeannationalweekly.com/contact/">Contact Us</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy;                 </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

				<style>
					.vdgk_sticky.vdgk_sticky_play {
						margin: 0px;
						will-change: position, transform, opacity;
						position: fixed !important;
						z-index: 9;
						width: 300px;
						height:225px;
						padding: 1px;
						bottom: 20px;
						right: 20px;
						background-color: #000;
					}
					@media (max-width:480px){
						.vdgk-video-wrapper,
						.vdgk-myVideo{
							width: 100% !important;
							height: 160px !important;
						}
						.vdgk_sticky.vdgk_sticky_play{
							width:200px !important;	
							bottom: 10px;
							right: 10px;
							height: 160px;
						}						
					}
				</style>
									<script>
						jQuery('.vdgk-sticky_vd').show(0).draggable({   containment: "window"   });
						var handle = jQuery( ".vdgk-sticky_vd" ).draggable( "option", "handle" );
						jQuery('.vdgk-sticky_vd').draggable( "option", "handle", '.vdgk_video_draggable' );
						
						
					</script>
					                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_1 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.caribbeannationalweekly.com/lifestyle/home-confinement-because-of-covid-19-doesnt-need-to-be-boring/" rel="bookmark" title="Home Confinement because of COVID-19 Doesn’t Need to be Boring"><img width="324" height="160" class="entry-thumb" src="https://www.caribbeannationalweekly.com/wp-content/uploads/2020/03/indoor-activities-324x160.jpg" alt="" title="Home Confinement because of COVID-19 Doesn’t Need to be Boring"/></a></div>                            </div>
            <h3 class="entry-title td-module-title"><a href="https://www.caribbeannationalweekly.com/lifestyle/home-confinement-because-of-covid-19-doesnt-need-to-be-boring/" rel="bookmark" title="Home Confinement because of COVID-19 Doesn’t Need to be Boring">Home Confinement because of COVID-19 Doesn’t Need to be Boring</a></h3>
            <div class="td-module-meta-info">
                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-25T17:41:17+00:00" >March 25, 2020</time></span>                            </div>

            
        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.2 (rara)
        Deploy mode: deploy
        
        uid: 5e7c94c9c8f4c
    -->

    <script>
    jQuery(document).ready(function () {
		jQuery.post('https://www.caribbeannationalweekly.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><link rel='stylesheet' id='dfp-css'  href='https://www.caribbeannationalweekly.com/wp-content/plugins/doubleclick-for-wp/css/dfp.css?ver=0.3.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/lazy-load-videos-and-sticky-control/assets/js/llvasc-public.min.js?ver=1.0.2'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.2'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-includes/js/comment-reply.min.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-includes/js/wp-embed.min.js?ver=b99ec9fefa475ed9eec1186276052eb8'></script>
<script async="async" type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.1'></script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/doubleclick-for-wp/js/vendor/jquery.dfp.js/jquery.dfp.js?ver=0.3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dfw = {"dfpID":"xxxxxx","network_code":"xxxxxx","mappings":[],"targeting":{"Page":["single"],"Category":["caribbean-breaking-news-featured","local-news","news"],"Tag":["broward-county","coronavirus","covid-19","effects","financial","impact","social"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.caribbeannationalweekly.com/wp-content/plugins/doubleclick-for-wp/js/jquery.dfw.js?ver=0.3.0'></script>
			<script type="text/javascript">
				jQuery('.dfw-unit:not(.dfw-lazy-load)').dfp( window.dfw );
			</script>
		
<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[43740]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.caribbeannationalweekly.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.caribbeannationalweekly.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


</body>
</html>